JPDiag Forum Index

JPDiag


 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

VAG KKL CH340T hard wiring Pin 16 and pin 7

 
Post new topic   Reply to topic    JPDiag Forum Index -> JPDiag -> International section
Previous topic :: Next topic  
Author Message
Pilaf
Map

Offline

Joined: 10 Nov 2016
Posts: 4
Localisation: The Netherlands
Masculin

PostPosted: Sat 12 Nov - 00:04 (2016)    Post subject: VAG KKL CH340T hard wiring Pin 16 and pin 7 Reply with quote

First of all, big complement to JP and his diag program. Also the forum is very usefully for a dummy like me.

Whats the plan and whats the problem.
First I want to connect JPdiag to my Vespa GTS300 2014 with an IAWM3G.E07 ECU (MIU family?)
I have ordered the VAG KKL cable and Fiat cable via ebay as mentioned in the faq and howto's.
Today my cables arrived and used the multimeter to be sure the + and - were correct connected in the fiat cable (+ red clamp to pin 16 and - clamp to pin 5 and the k-line to pin 7) and that was the case.


I tried to install the ftdi drivers, without succes. The CH340 drivers for WCH from the FAQ worked fine.
So the cable is on COM 4, connected the red and black clamp and started the cable test. Test 1 (12v/0v k-line) was ok but test 2 not.
Then I connected the fiat cable to my diagnose plug and started the program. 
There was no ECU information presented on COM4 and the program stays on connecting.
Then I checked the FAQ again and on the top it says to check pin 4 and 5 (ground) and hardwire them in case of a CH340 chipset.
So I opened the VAG KKL connector and this is what I found. Pin 7 is hard wired with pin 16 and pin 15 is hard wired with pin 6.


So what happened, I have put 12v from the battery direct to the K-line without knowing it. 


Luckely the Vespa is still starting, but did I damage the k-line because of this wiring? And how can I check with the multimeter that the k-line is still working?


And how can I recognize the right GAG KKL cable because on ebay/amazon they all look the same as my cable.
I have no clue if I can rewire/soldering this cable so I can connect the 12v, gnd and k-line separate, so I think the wisest thing is to buy a new one.


Regards,


Olaf








Back to top
Publicité






PostPosted: Sat 12 Nov - 00:04 (2016)    Post subject: Publicité

PublicitéSupprimer les publicités ?
Back to top
chrisw
FLASH

Offline

Joined: 10 Aug 2010
Posts: 1,999
Localisation: Enjoying Retirement !!!!

PostPosted: Sat 12 Nov - 15:29 (2016)    Post subject: VAG KKL CH340T hard wiring Pin 16 and pin 7 Reply with quote

Buy FTDI

http://www.ebay.co.uk/itm/TuneEcu-compatible-lead-map-and-software-KKL-FTDI-black-/161743974836?hash=item25a8b131b4:g:io8AAOSwGvhUDGzp
_________________


Back to top
Pilaf
Map

Offline

Joined: 10 Nov 2016
Posts: 4
Localisation: The Netherlands
Masculin

PostPosted: Sat 12 Nov - 23:22 (2016)    Post subject: VAG KKL CH340T hard wiring Pin 16 and pin 7 Reply with quote

Thanks for the link and i have ordered one. Hope this one will work on my iawm3g and hopefully my k-line is not destroyed.

Then a warning when buying cheap cables at amazon/ebay. Open them first before connecting, they will past the jp test but they are wired the wrong way. I have some more pictures so you can recognize them.










Back to top
jpl250rs
Administrateur

Offline

Joined: 05 Jun 2010
Posts: 10,792
Masculin
Bike / Moto: 899

PostPosted: Sun 13 Nov - 12:27 (2016)    Post subject: VAG KKL CH340T hard wiring Pin 16 and pin 7 Reply with quote

if you can modulate with 0v or 12v the kline then it should be ok . double check it with with multimeter.then if test2 is successfull , then there is no reason it can't work

Back to top
MSN
Pilaf
Map

Offline

Joined: 10 Nov 2016
Posts: 4
Localisation: The Netherlands
Masculin

PostPosted: Mon 14 Nov - 19:35 (2016)    Post subject: VAG KKL CH340T hard wiring Pin 16 and pin 7 Reply with quote

I don't see how to modulate with 0v or 12v over the k-line, with a cable which has a hard wire 12v wire on the k-line.
With the cable above test 1 and test 2 are ok when i connect the croc clamps from my fiat cable (red 12v and black 0v) to the battery.
When i also connect the cable to my diagose connector of my vespa the tests fail and even your diag program crashes (both on xp and 7).
After the failed test i opened the cable with the findings above.
The new cable suggested by chrisw is on its way and the other one goes in the bin.
I want a cable which is plug and play with your program and don't mess with my ECU because i don't have the knowledge of how a k-line works.


Back to top
jpl250rs
Administrateur

Offline

Joined: 05 Jun 2010
Posts: 10,792
Masculin
Bike / Moto: 899

PostPosted: Mon 14 Nov - 20:04 (2016)    Post subject: VAG KKL CH340T hard wiring Pin 16 and pin 7 Reply with quote

i though it was ok , in this case u maybe missed a pull up resistor.
but it's not working , no need to try to connect the cable to the bike
Pilaf wrote:
Test 1 (12v/0v k-line) was ok but test 2 not.



Back to top
MSN
Pilaf
Map

Offline

Joined: 10 Nov 2016
Posts: 4
Localisation: The Netherlands
Masculin

PostPosted: Tue 22 Nov - 15:27 (2016)    Post subject: VAG KKL CH340T hard wiring Pin 16 and pin 7 Reply with quote

Today I received the new FTDI cable from the link above.
Test 1 and test 2 are now ok, however when the cable is connected to the Diagnose connector of my Vespa GTS300 it is not responding.
I have tried both slow and fast int without success.

So what I do to connect to jpdiag.
Do the test (cable is on com3 in device manager) in the jpdiag program, test 1 and 2 ok.





Then connect the cable to diagnose plug.
Start connection on com3 in jp diag (slow init)
Turn ignition on and wait.





Waited for 5 minutes without success.

There is however a text above the slow/fast init: 8FEF




Use FTDI driver version 24 (from the FAQ) and Windows 7 Starter on a Dell mini 10v (clean installation of windows 7).

Any suggestions?


UPDATE: I have also tried jpdiag on a Windows XP Pro sp3 laptop also with the FTDI version 24 without luck. Again test 1 and 2 are ok but when I press connect (both slow and fast) it starts connecting and after a couple of seconds a small message apears (8fef) and the connecting message dissapears. However, no information about the ECU is presented.

Then I tried IAWDiag v0.47 and now my ECU is communicating with both laptops and sending all the data.
So luckely my k-line is not blown by the other cable.

UPDATE 2: the new cable is working fine with JPdiag on an older Vespa GTS with a MIU ECU.
My conclusion is that JPdiag is not working on a MIU3G ECU, is my conclusion correct?


UPDATE 3: Problem solved and jpdiag is working fine with the new cable thanks to the JP tip. I removed all the previous drivers, reinstalled v24 on the windows xp machine and the latest from the ftdi site for my windows 7 starter machine. Reinstalled jpdiag now with the GALETTO settings and the MIU3G is recognized and communicating with jpdiag.


Great job JP and thanks for your quick reply on my PM.
Regards from a happy Vespa owner.


Back to top
Contenu Sponsorisé






PostPosted: Today at 19:35 (2019)    Post subject: VAG KKL CH340T hard wiring Pin 16 and pin 7

Back to top
Display posts from previous:   
Post new topic   Reply to topic    JPDiag Forum Index -> JPDiag -> International section All times are GMT + 1 Hour
Page 1 of 1

 
Jump to:  

Index | Administration Panel | Create a free forum | Free support forum | Free forums directory | Report a violation | Conditions générales d'utilisation
Powered by phpBB © 2001, 2005 phpBB Group