JPDiag Forum Index

JPDiag


 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

M3D ECUs
Goto page: 1, 2  >
 
Post new topic   Reply to topic    JPDiag Forum Index -> JPDiag -> M3C / Mitsu ecus
Previous topic :: Next topic  
Author Message
Derek
Map

Offline

Joined: 25 Aug 2010
Posts: 58
Localisation: Scotland
Masculin

PostPosted: Thu 19 Oct - 19:19 (2017)    Post subject: M3D ECUs Reply with quote

Is there any work ongoing for the new Continental M3D ECUs fitted to the new Supersport, Hypermotard, MTS950 and possibly some of the other new models?

Back to top
Publicité






PostPosted: Thu 19 Oct - 19:19 (2017)    Post subject: Publicité

PublicitéSupprimer les publicités ?
Back to top
jpl250rs
Administrateur

Offline

Joined: 05 Jun 2010
Posts: 9,860
Masculin
Bike / Moto: 899

PostPosted: Thu 19 Oct - 20:15 (2017)    Post subject: M3D ECUs Reply with quote

melcodiag is ready for reset service light
i miss some user feedbacks to get it working


Back to top
MSN
Derek
Map

Offline

Joined: 25 Aug 2010
Posts: 58
Localisation: Scotland
Masculin

PostPosted: Sat 21 Oct - 10:04 (2017)    Post subject: M3D ECUs Reply with quote

I have Melcodiag from when I had the MTS1200. I will try connecting and see what it shows and send a request for a licence for the SS. It will be some time before it requires a service reset though.

Back to top
jpl250rs
Administrateur

Offline

Joined: 05 Jun 2010
Posts: 9,860
Masculin
Bike / Moto: 899

PostPosted: Sat 21 Oct - 10:40 (2017)    Post subject: M3D ECUs Reply with quote

you need to download latest version
your bike should be recognize else i need to patch software


Back to top
MSN
Derek
Map

Offline

Joined: 25 Aug 2010
Posts: 58
Localisation: Scotland
Masculin

PostPosted: Tue 31 Oct - 13:13 (2017)    Post subject: M3D ECUs Reply with quote

I have now succeeded in getting a connection to the SS939 and have a licence from JP. However there doesn't seem to be much difference with or without the licence.
The main screen shows the bike model, the bike volts seem to be correct but the ELM voltage definitely isn't. Engine and ambient temperatures seem to be out by a factor of around -50º, the mileage shown is less than half what it is and the rpm is hugely out and doesn't respond in real time.
The DTC screen shows no DTC errors but I wouldn't expect any. I can test the fans and the exh valve but nothing more. The BBU info shows incorrect values for ABS and DTC. The gear position is shown as 2 when it should be N but the fuel quantity seems to be about right at 6.67L.
I don't know if any service warnings can be reset as none are due yet. I have nearly 2 years to find out.
Now that I have a connection I'm happy to do any tests that will help JP improve the app.




Back to top
jpl250rs
Administrateur

Offline

Joined: 05 Jun 2010
Posts: 9,860
Masculin
Bike / Moto: 899

PostPosted: Tue 31 Oct - 18:51 (2017)    Post subject: M3D ECUs Reply with quote

to fix  the 1st page display you can post the debug file content here and the values of air temp , engine temp etc ..

Back to top
MSN
Derek
Map

Offline

Joined: 25 Aug 2010
Posts: 58
Localisation: Scotland
Masculin

PostPosted: Wed 1 Nov - 16:01 (2017)    Post subject: M3D ECUs Reply with quote

Below is the debug file as requested.


"File generated On 01/11/2017 14:35:30"
"Software version 1.0.4.6"
"ELM version : ELM327 v1.5"


"Auto Detect Bike = SuperSport 939"
"User Bike = Supersport 939/ 2017"


"CAN Bike = "
"Ecu = UUUUU"
"Hardw = ìA2C"
"Softw = 95514431"
"OilService = NO"
"DesmoService = NO"


"PID 18 = 0002A00040C04034"
"PID 80 = 2952950300A00F8D"
"PID 100 = C812070000000E92"
"PID 210 = 0000003000005E1D"
"PID 300 = 34840002053589CD"
"Vin = ZDMVA00AAHB003343"
"DTC =  0258000000000000"
"6CE25D08"



Actual air temperature was 12ºC, indicated was -40ºC. Engine was newly started so temperature should have been much the same although indication was -40ºC with engine stopped but -36ºC when started.
Engine speed as 1300 rpm, indication in Melcodiag was -24563. Mileage is 3315 (5334 km), indication in Melcodiag is 1333 km.


Back to top
jpl250rs
Administrateur

Offline

Joined: 05 Jun 2010
Posts: 9,860
Masculin
Bike / Moto: 899

PostPosted: Wed 1 Nov - 20:33 (2017)    Post subject: M3D ECUs Reply with quote

that's the good way to proceed.by the way i upgraded the report tool , because i think i miss some data.
can you download latest version 1.0.5.1
and make 2 reports at least, with different values temp , rpm ?


Back to top
MSN
Derek
Map

Offline

Joined: 25 Aug 2010
Posts: 58
Localisation: Scotland
Masculin

PostPosted: Wed 1 Nov - 20:42 (2017)    Post subject: M3D ECUs Reply with quote

I've downloaded the new version. I will try it tomorrow.

Back to top
Derek
Map

Offline

Joined: 25 Aug 2010
Posts: 58
Localisation: Scotland
Masculin

PostPosted: Thu 2 Nov - 11:56 (2017)    Post subject: M3D ECUs Reply with quote

I connected Melcodiag V1.0.5.1 today and found a few differences.
Main ECU and BBS ECU remained grey, Dashboard light green.
"Refresh every 10s" for engine and air temps is greyed out and no values for these parameters are shown


I did the first report with the engine off and throttle closed.
RPM is shown = 8200 and APS = 35, volts = 12.4


"File generated On 02/11/2017 10:05:25"
"Software version 1.0.5.1"
"ELM version : ELM327 v1.5"


"Auto Detect Bike = SuperSport 939"
"User Bike = sPERSPORT 939 2017"


"CAN Bike = "
"Main ecu is not detected"
"BBS ecu is not detected"
"DashBoard ecu is detected"
"Ecu = UUUUU"
"Hardw = ìA2C"
"Softw = 95514431"
"OilService = NO"
"DesmoService = NO"


"
12 PIDS active founds
 : 
188 : 8001800180010A0D
022 : 000000000003FA73
023 : 0000005480010AAB
018 : 0002A00040C04AE6
019 : 9609600000000A01
024 : 0000000000000230
080 : 2082080305200242
100 : C812004000000291
020 : 00405010000009FB
BUF : FER FULL
 : 
> : 
"
"Vin = ZDMVA00AAHB003343"
"DTC =  0258000000000000"
"6CE25D08"



 Next report is with bike idling at 1300rpm
rpm shown = -24575, aps = 42


"File generated On 02/11/2017 10:17:38"
"Software version 1.0.5.1"
"ELM version : ELM327 v1.5"


"Auto Detect Bike = "
"User Bike = swUPWERSPORT 939 2017"


"CAN Bike = "
"Main ecu is not detected"
"BBS ecu is not detected"
"DashBoard ecu is detected"
"Ecu = UUUUU"
"Hardw = ìA2C"
"Softw = 95514431"
"OilService = NO"
"DesmoService = NO"


"
13 PIDS active founds
 : 
020 : 0040500000000136
100 : C812068000000BA4
188 : 80018001800101C2
022 : 000000000003F1BC
023 : 0000005480010164
018 : 0002A00040C0420E
019 : 96096000000002E9
024 : 00020B2400003C9D
080 : 2AA2A90300A00C6C
210 : 000000340000F054
BUF : FER FULL
 : 
> : 
"
"Vin = "
"DTC =  NO DATA"
"6CE25D08"


Finally I tried to do a report at higher revs but found this quite difficult, clicking the REPORT button while balancing the netbook on the tank. I managed to do this around about 2,000 rpm but cannt be sure of the revs. Nor did I note the rpm and aps values in Melcodiag.


"File generated On 02/11/2017 10:20:01"
"Software version 1.0.5.1"
"ELM version : ELM327 v1.5"


"Auto Detect Bike = "
"User Bike = supersport 939 2017"


"CAN Bike = "
"Main ecu is not detected"
"BBS ecu is not detected"
"DashBoard ecu is detected"
"Ecu = UUUUU"
"Hardw = ìA2C"
"Softw = 95514431"
"OilService = NO"
"DesmoService = NO"


"
13 PIDS active founds
 : 
024 : 00020B3600003AD1
080 : 2BF2BE0300A00ADE
100 : C812048000000A6D
020 : 0040500000000211
018 : 0002A00040C0455D
019 : 96096000000005BA
188 : 8001800180010691
022 : 000000000003F6EF
023 : 0000005480010637
230 : 00800C0000000DE9
BUF : FER FULL
 : 
> : 
"
"Vin = "
"DTC =  NO DATA"
"6CE25D08"












Back to top
Derek
Map

Offline

Joined: 25 Aug 2010
Posts: 58
Localisation: Scotland
Masculin

PostPosted: Thu 2 Nov - 11:57 (2017)    Post subject: M3D ECUs Reply with quote

I should also add that on several occasions Melcodiag froze after creating the bug report and I had to use Task Manager to quit it.

Back to top
jpl250rs
Administrateur

Offline

Joined: 05 Jun 2010
Posts: 9,860
Masculin
Bike / Moto: 899

PostPosted: Thu 2 Nov - 22:28 (2017)    Post subject: M3D ECUs Reply with quote

nice  Okay
now we'll try to find the different temperature , but you forgot to write it down
mileage and rpm for starting
knowing that temperature is value -40
example  12°c should be  12 + 40  = 52 in decimal (52d)= 34 in hex (34h)






14bits should be enough for rpm but i guess it's expressed with 2bytes : 1300d = 0514h


200000km is 030D40 so we expect at least 18 bits
mileage 3315mil = 5304km  = 0014B8h
i can't find it in your record maybe mileage change since yesterday ?


Back to top
MSN
Derek
Map

Offline

Joined: 25 Aug 2010
Posts: 58
Localisation: Scotland
Masculin

PostPosted: Fri 3 Nov - 10:17 (2017)    Post subject: M3D ECUs Reply with quote

No the mileage was the same. I will do the tests again, today or tomorrow but the milage is now more. I will write down actual rpm, ambient temperature and mileage when I do the tests.

Back to top
Derek
Map

Offline

Joined: 25 Aug 2010
Posts: 58
Localisation: Scotland
Masculin

PostPosted: Sun 5 Nov - 12:30 (2017)    Post subject: M3D ECUs Reply with quote

3 more debug files.


1. Engine OFF


Mileage : 3347 miles on dash = 5386 km
Displayed Ambient = 6ºC, Engine temperature not shown
rpm = 0
Melcodiag shows: rpm = 8203 , APS = 32, Battery Voltage = 12.4V


"File generated On 05/11/2017 10:48:55"
"Software version 1.0.5.1"
"ELM version : ELM327 v1.5"


"Auto Detect Bike = SuperSport 939"
"User Bike = Supersport 939 2017"


"CAN Bike = "
"Main ecu is not detected"
"BBS ecu is not detected"
"DashBoard ecu is detected"
"Ecu = UUUUU"
"Hardw = ìA2C"
"Softw = 95514431"
"OilService = NO"
"DesmoService = NO"


"
12 PIDS active founds
 : 
188 : 80018001800103F8
022 : 000000000003F386
023 : 000000548001035E
100 : C812004000000C37
018 : 0002A00040C04440
019 : 96096000000004A7
024 : 0000000000000D8B
080 : 2032030305200DAC
020 : 0040501000000329
BUF : FER FULL
 : 
> : 
"
"Vin = ZDMVA00AAHB003343"
"DTC =  0258000000000000"
"6CE25D08"


2. Engine ON


Mileage : 3347 miles on dash = 5386 km
Displayed Ambient = 6ºC,  Engine temperature not shown
rpm = 1300 ( varies between 1250 and 1400 on dash but mainly 1300)
Melcodiag shows: rpm = -24573 (also varies slightly approx ± 10) , APS = 44. Battery voltage = 13.9V


"File generated On 05/11/2017 10:56:45"
"Software version 1.0.5.1"
"ELM version : ELM327 v1.5"


"Auto Detect Bike = "
"User Bike = SS939 2017"


"CAN Bike = "
"Main ecu is not detected"
"BBS ecu is not detected"
"DashBoard ecu is detected"
"Ecu = UUUUU"
"Hardw = ìA2C"
"Softw = 95514431"
"OilService = NO"
"DesmoService = NO"


"
12 PIDS active founds
 : 
024 : 00020AE200000D68
080 : 2CB2C90300A00DE8
188 : 80018001800103F8
022 : 000000000003F386
023 : 000000548001035E
020 : 004050000000030C
100 : C812058000000D54
018 : 0002A00040C04440
019 : 96096000000004A7
BUF : FER FULL
 : 
> : 
"
"Vin = "
"DTC =  NO DATA"
"6CE25D08"


3. Engine ON (Seems like something went wrong with this one as there is no PID data)


Mileage : 3347 miles on dash = 5386 km
Displayed Ambient = 7ºC,  Engine temperature = 60ºC
rpm = 1300 ( varies between 1250 and 1400 on dash but mainly 1300)
Melcodiag shows: rpm = -24573 (also varies slightly approx ± 10) , APS = 44. Battery voltage = 13.9



"File generated On 05/11/2017 11:00:18"
"Software version 1.0.5.1"
"ELM version : ELM327 v1.5"


"Auto Detect Bike = "
"User Bike = SS939 2017"


"CAN Bike = "
"Main ecu is not detected"
"BBS ecu is not detected"
"DashBoard ecu is not detected"
"Ecu = "
"Hardw = "
"Softw = "
"OilService = NO"
"DesmoService = NO"


""
"Vin = "
"DTC =  NO DATA"
"6CE25D08"



Back to top
jpl250rs
Administrateur

Offline

Joined: 05 Jun 2010
Posts: 9,860
Masculin
Bike / Moto: 899

PostPosted: Sun 5 Nov - 15:53 (2017)    Post subject: M3D ECUs Reply with quote

good job Okay
just so bad we didn't got the pids on the last report


i'm trying to find the good data now ....


Back to top
MSN
Contenu Sponsorisé






PostPosted: Today at 00:06 (2017)    Post subject: M3D ECUs

Back to top
Display posts from previous:   
Post new topic   Reply to topic    JPDiag Forum Index -> JPDiag -> M3C / Mitsu ecus All times are GMT + 1 Hour
Goto page: 1, 2  >
Page 1 of 2

 
Jump to:  

Index | Administration Panel | Create a free forum | Free support forum | Free forums directory | Report a violation | Conditions générales d'utilisation
Powered by phpBB © 2001, 2005 phpBB Group