JPDiag Forum Index

JPDiag


 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

Problem with TPS - error code P0120
Goto page: 1, 2  >
 
Post new topic   Reply to topic    JPDiag Forum Index -> JPDiag -> International section
Previous topic :: Next topic  
Author Message
Julesw
FLASH

Offline

Joined: 02 Apr 2018
Posts: 30
Localisation: Holland
Masculin

PostPosted: Tue 1 May - 14:48 (2018)    Post subject: Problem with TPS - error code P0120 Reply with quote

Hi Guys,
I have a 848 SF from 2012.
Rexxer tuning, no exhaust flap, no lambda, sc project exhaust.



I keep getting the error code of the TPS, P0120.


Unfortunately it doesn't always occur, so I am wondering what it could be.

What I did:
- checked ECU ground for corrosion
- checked the plugs from ecu, tps, added a little contact cleaner
- replace tps sensor
- erase error code
- reset tps 


The new sensor seems to work good from about 3 - 85 degrees.


Sometimes I can drive 40+ kms with no trouble, sometimes the error comes back and then the bike only runs idle. When I restart sometimes the error is gone and I can drive normally. Sometimes the error stays for a longer period.


The problems are combined with extreme fuel consumption since I own the bike.


Anyone have any idea where to look?


Back to top
Publicité






PostPosted: Tue 1 May - 14:48 (2018)    Post subject: Publicité

PublicitéSupprimer les publicités ?
Back to top
jpl250rs
Administrateur

Offline

Joined: 05 Jun 2010
Posts: 10,308
Masculin
Bike / Moto: 899

PostPosted: Tue 1 May - 16:05 (2018)    Post subject: Problem with TPS - error code P0120 Reply with quote

looks like harness problem or ecu problem
did you try an other ecu ?


Back to top
MSN
Julesw
FLASH

Offline

Joined: 02 Apr 2018
Posts: 30
Localisation: Holland
Masculin

PostPosted: Wed 2 May - 20:47 (2018)    Post subject: Problem with TPS - error code P0120 Reply with quote

Hi Jp,
No I don't have another ECU.


Today I tested once again. The engine light only fires sometimes. Most of the time it is off


It seemed to me that it lighted when speeding and with speed bumps.


Today it stayed on so I tried twisting some wires of the harness. At one point I could let the light go on and off  (the error) by squeezing.


So I think that should be the problem, it is near ECU which has been replaced by a dealer last year.


The most frustrating; 10 minutes later the engine light was gone and I couldn't reproduce the error by squeezing!!!


Could it be a coincidence or should I be sure about a crack in a cable?


Back to top
jpl250rs
Administrateur

Offline

Joined: 05 Jun 2010
Posts: 10,308
Masculin
Bike / Moto: 899

PostPosted: Thu 3 May - 09:03 (2018)    Post subject: Problem with TPS - error code P0120 Reply with quote

It’s a good star if you localize the harness problem
Now you need to open it and squeeze cable one by one to find the one that is broken


Back to top
MSN
riderlogic
FLASH

Offline

Joined: 01 Mar 2012
Posts: 372
Localisation: Melbourne, Australia
Masculin Gémeaux (21mai-20juin)

PostPosted: Sat 5 May - 09:53 (2018)    Post subject: Problem with TPS - error code P0120 Reply with quote

From memory, that was a open circuit on the signal wire.  Wriggle the wires near both the ECU and TPS connectors.  


But most likely a wiring loom issue.


Back to top
Visit poster’s website Skype
Julesw
FLASH

Offline

Joined: 02 Apr 2018
Posts: 30
Localisation: Holland
Masculin

PostPosted: Sat 5 May - 11:43 (2018)    Post subject: Problem with TPS - error code P0120 Reply with quote

The bike doesnt run well anymore.

There is no error code but tps only goes to 28,5, also after reset.

I'm sick of it... I think I should try another ECU or send it to a lab for testing


Back to top
jpl250rs
Administrateur

Offline

Joined: 05 Jun 2010
Posts: 10,308
Masculin
Bike / Moto: 899

PostPosted: Sat 5 May - 14:01 (2018)    Post subject: Problem with TPS - error code P0120 Reply with quote

You mean full throttle you reach only 28.5?
If so take all voltage closed and full throttle on the tps directly


Back to top
MSN
Julesw
FLASH

Offline

Joined: 02 Apr 2018
Posts: 30
Localisation: Holland
Masculin

PostPosted: Sat 5 May - 14:10 (2018)    Post subject: Problem with TPS - error code P0120 Reply with quote

Yes indeed thats What i mean. 


What do you mean with the voltage?


Back to top
riderlogic
FLASH

Offline

Joined: 01 Mar 2012
Posts: 372
Localisation: Melbourne, Australia
Masculin Gémeaux (21mai-20juin)

PostPosted: Sat 5 May - 14:49 (2018)    Post subject: Problem with TPS - error code P0120 Reply with quote

Measure voltage going across sensor plug. Should be 4.9volts or a bit higher. If you have a wiring issue, then it could give ecu wrong voltage signal.

Back to top
Visit poster’s website Skype
Julesw
FLASH

Offline

Joined: 02 Apr 2018
Posts: 30
Localisation: Holland
Masculin

PostPosted: Sun 6 May - 12:37 (2018)    Post subject: Problem with TPS - error code P0120 Reply with quote

3,4 volts. Too low?


You Guys think it is wiring related or should i try another ecu first?


Back to top
jpl250rs
Administrateur

Offline

Joined: 05 Jun 2010
Posts: 10,308
Masculin
Bike / Moto: 899

PostPosted: Sun 6 May - 12:53 (2018)    Post subject: Problem with TPS - error code P0120 Reply with quote

3.4v seems a bit low
you miss at least 1 volt


Back to top
MSN
Julesw
FLASH

Offline

Joined: 02 Apr 2018
Posts: 30
Localisation: Holland
Masculin

PostPosted: Mon 7 May - 10:34 (2018)    Post subject: Problem with TPS - error code P0120 Reply with quote

Should it be 4.9 on both + ?
Because one is 0.9 and the other 3.4


Back to top
jpl250rs
Administrateur

Offline

Joined: 05 Jun 2010
Posts: 10,308
Masculin
Bike / Moto: 899

PostPosted: Mon 7 May - 12:16 (2018)    Post subject: Problem with TPS - error code P0120 Reply with quote

it's a variable resistor.
1 pin is gnd , 1 pin is +5V, and the output pin varies from 0 to 5V


Back to top
MSN
Julesw
FLASH

Offline

Joined: 02 Apr 2018
Posts: 30
Localisation: Holland
Masculin

PostPosted: Mon 7 May - 12:24 (2018)    Post subject: Problem with TPS - error code P0120 Reply with quote

Helpful picture thank you 


I think the variable one didn’t do much. Will test again tonight. I will also check the resistance of the tps related cables. If that’s all well The problem should be ecu related I guess 


Back to top
chrisw
FLASH

Offline

Joined: 10 Aug 2010
Posts: 1,993
Localisation: Enjoying Retirement !!!!

PostPosted: Mon 7 May - 15:33 (2018)    Post subject: Problem with TPS - error code P0120 Reply with quote

You need to read the voltage from pin A and pin C. The two outer ones. Is the TPS on the front throttle body? If so volts low = Throttle wide open. Volts high = throttle closed. If the TPS is on the rear throttle body then volts low = throttle closed and volts high = TWO


On my 1198S throttle closed = 4.71v and TWO = 0.86v
_________________
This guy looks after my bike
http://www.ducati-john.co.uk/


Back to top
Visit poster’s website
Contenu Sponsorisé






PostPosted: Today at 10:15 (2018)    Post subject: Problem with TPS - error code P0120

Back to top
Display posts from previous:   
Post new topic   Reply to topic    JPDiag Forum Index -> JPDiag -> International section All times are GMT + 1 Hour
Goto page: 1, 2  >
Page 1 of 2

 
Jump to:  

Index | Administration Panel | Create a free forum | Free support forum | Free forums directory | Report a violation | Conditions générales d'utilisation
Powered by phpBB © 2001, 2005 phpBB Group