JPDiag Forum Index

JPDiag


 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

Monster 620 TPS help!
Goto page: 1, 2, 3  >
 
Post new topic   Reply to topic    JPDiag Forum Index -> JPDiag -> International section
Previous topic :: Next topic  
Author Message
Parabellum
Map

Offline

Joined: 07 Aug 2018
Posts: 20
Localisation: Australia
Masculin
Bike / Moto: Monster 620

PostPosted: Tue 7 Aug - 11:48 (2018)    Post subject: Monster 620 TPS help! Reply with quote

Hi guys, 
I have a 2002 620 monster that I bought not running. (No dash or keys came with the bike) I have fit a brand new dash and had keys cut and had the ecu immobiliser reset to virgin state. I now have the bike running but it is very very rich. I downloaded jpdiag and found that the TPS values are not working properly. The throttle angle was constantly at 85 degrees. When I removed the TPS from the bike it sprang back a little and then read 2.90 deg. When I turn the Tps it goes fro 2.9 deg straight to 85 deg with nothing in between. I have tried a new tps and tested the wiring back to the ecu. Also the co trim is at 104 !!
I would really appreciate any help or ideas.
Thanks in advance.


Back to top
Publicité






PostPosted: Tue 7 Aug - 11:48 (2018)    Post subject: Publicité

PublicitéSupprimer les publicités ?
Back to top
chrisw
FLASH

Offline

Joined: 10 Aug 2010
Posts: 1,993
Localisation: Enjoying Retirement !!!!

PostPosted: Tue 7 Aug - 15:56 (2018)    Post subject: Monster 620 TPS help! Reply with quote

Is the TPS non-linear (slots to rotate) or linear (no manual adjustment)
_________________
This guy looks after my bike
http://www.ducati-john.co.uk/


Back to top
Visit poster’s website
Parabellum
Map

Offline

Joined: 07 Aug 2018
Posts: 20
Localisation: Australia
Masculin
Bike / Moto: Monster 620

PostPosted: Tue 7 Aug - 20:13 (2018)    Post subject: Monster 620 TPS help! Reply with quote

Hi, It’s slotted, non linear.
Thanks.


Back to top
jpl250rs
Administrateur

Offline

Joined: 05 Jun 2010
Posts: 10,308
Masculin
Bike / Moto: 899

PostPosted: Tue 7 Aug - 20:44 (2018)    Post subject: Monster 620 TPS help! Reply with quote

you read 4.8V on the output wire on every throttle position ?

Back to top
MSN
Parabellum
Map

Offline

Joined: 07 Aug 2018
Posts: 20
Localisation: Australia
Masculin
Bike / Moto: Monster 620

PostPosted: Tue 7 Aug - 21:29 (2018)    Post subject: Monster 620 TPS help! Reply with quote

Not 100% sure but when I test the tps resistance at the ecu harness connector (ecu disconnected) the value rises smoothly as you turn the tps.
I suspect there may be an ecu issue.


Back to top
jpl250rs
Administrateur

Offline

Joined: 05 Jun 2010
Posts: 10,308
Masculin
Bike / Moto: 899

PostPosted: Tue 7 Aug - 22:20 (2018)    Post subject: Monster 620 TPS help! Reply with quote

yes it could be 
test the voltage on the 3 pin then you'll see better


Back to top
MSN
Parabellum
Map

Offline

Joined: 07 Aug 2018
Posts: 20
Localisation: Australia
Masculin
Bike / Moto: Monster 620

PostPosted: Wed 8 Aug - 10:13 (2018)    Post subject: Monster 620 TPS help! Reply with quote

Hi guys, Ok so I read 5 volts to the centre wire and I read a nice progressive increase between the orange wire and earth or between the outside two wires. All seems good there. Something I forgot to mention, if I disconnect the TPS while running and connected to the diag software the TPS value drifts around between 2.9 deg up to maybe 25 deg or so and seems to roughly increase with throttle opening.
Thanks guys.


Back to top
Parabellum
Map

Offline

Joined: 07 Aug 2018
Posts: 20
Localisation: Australia
Masculin
Bike / Moto: Monster 620

PostPosted: Wed 8 Aug - 10:18 (2018)    Post subject: Monster 620 TPS help! Reply with quote

I meant to ask, are these iaw59 ecu’s prone to failure?

Back to top
jpl250rs
Administrateur

Offline

Joined: 05 Jun 2010
Posts: 10,308
Masculin
Bike / Moto: 899

PostPosted: Wed 8 Aug - 10:40 (2018)    Post subject: Monster 620 TPS help! Reply with quote

it can fail on ignition coil output
i never hear it can fail on tps input.
i would check the loom ecu side taking the tps output voltage there


Back to top
MSN
Parabellum
Map

Offline

Joined: 07 Aug 2018
Posts: 20
Localisation: Australia
Masculin
Bike / Moto: Monster 620

PostPosted: Wed 8 Aug - 11:01 (2018)    Post subject: Monster 620 TPS help! Reply with quote

Hi, yes I have tested the harness, all seems good. Def no coil problems, bike runs, is just very very rich.

Back to top
Parabellum
Map

Offline

Joined: 07 Aug 2018
Posts: 20
Localisation: Australia
Masculin
Bike / Moto: Monster 620

PostPosted: Wed 8 Aug - 11:42 (2018)    Post subject: Monster 620 TPS help! Reply with quote

If I flash another ecu with the file from my current ecu will the immobiliser code information transfer across too?If not can you disable the immobiliser permanently. And lastly is it worthwhile to try reflashing another file to my ecu in case mine is corrupted?

Back to top
jpl250rs
Administrateur

Offline

Joined: 05 Jun 2010
Posts: 10,308
Masculin
Bike / Moto: 899

PostPosted: Wed 8 Aug - 14:01 (2018)    Post subject: Monster 620 TPS help! Reply with quote

no , you'll have to patch it with permanent immo off

Back to top
MSN
chrisw
FLASH

Offline

Joined: 10 Aug 2010
Posts: 1,993
Localisation: Enjoying Retirement !!!!

PostPosted: Wed 8 Aug - 20:18 (2018)    Post subject: Monster 620 TPS help! Reply with quote

At throttle closed what reading are you getting? Think it should be 150 to 165 mV. Adjust the TPS by rotating on the slots.
_________________
This guy looks after my bike
http://www.ducati-john.co.uk/


Back to top
Visit poster’s website
jpl250rs
Administrateur

Offline

Joined: 05 Jun 2010
Posts: 10,308
Masculin
Bike / Moto: 899

PostPosted: Wed 8 Aug - 20:40 (2018)    Post subject: Monster 620 TPS help! Reply with quote

Okay

Back to top
MSN
Parabellum
Map

Offline

Joined: 07 Aug 2018
Posts: 20
Localisation: Australia
Masculin
Bike / Moto: Monster 620

PostPosted: Wed 8 Aug - 20:45 (2018)    Post subject: Monster 620 TPS help! Reply with quote

Hi Chris, before I removed it it was reading something like 330 my at closed throttle. (ECU displayed 85 deg) after I removed it and it sprang back to fully closed it reads close to 150 but I can’t remember the exact figure (ECU reads 2.9 deg) as soon as I begin to turn the TPS it jumps straight to 85 deg on the ECU. At least that is what the software displays. I will retest and write down figures tonight.


JP, is the immobiliser off patch something I can do? If so could you advise what software I need.
Thanks again for the ideas guys. Okay


Back to top
Contenu Sponsorisé






PostPosted: Today at 10:38 (2018)    Post subject: Monster 620 TPS help!

Back to top
Display posts from previous:   
Post new topic   Reply to topic    JPDiag Forum Index -> JPDiag -> International section All times are GMT + 1 Hour
Goto page: 1, 2, 3  >
Page 1 of 3

 
Jump to:  

Index | Administration Panel | Create a free forum | Free support forum | Free forums directory | Report a violation | Conditions générales d'utilisation
Powered by phpBB © 2001, 2005 phpBB Group