JPDiag Forum Index

JPDiag


 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

Presentation

 
Post new topic   Reply to topic    JPDiag Forum Index -> JPDiag -> Présentation
Previous topic :: Next topic  
Author Message
briseis
Map

Offline

Joined: 02 Nov 2018
Posts: 2
Localisation: Lyon
Masculin

PostPosted: Fri 2 Nov - 11:28 (2018)    Post subject: Presentation Reply with quote

Bonjour à tous


J'ai une expérience de 30 ans de moto. Du coup, mon fils m'a demandé mon avis pour l'achat de sa première moto, une monster 695.
Je l'ai essayée, je l'ai trouvé plutôt bien, un peu difficile à bas régime, mais sinon "tout le reste était impeccable" et du coup il l'a achetée  Sad
En fait elle est "insupportable" a bas régime, et le problème est connu : 
Elle n'a qu'une sonde Lambda et l'ECU est incapable de régler correctement l'injection quand il est en boucle fermée (bas régime)
Ce défaut a d'ailleurs été reconnu par Ducati qui, si on "rallais", remplaçait gratuitement l'ECU d'origine par un ECU ducati performance qui ne prenait plus en compte la sonde Lambda. Malheureusement le premier propriétaire n'a pas fait jouer cette garantie et la moto à toujours l'ECU d'origine avec un bas régime "insupportable".


Comme je me sens responsable de cet achat, je cherche une solution.
J'ai donc acheté sur internet un ECU Ducati performance que je voulait "flasher"  mais je croit que j'ai fait ma deuxième erreur ...  Embarassed


- C'est un ECU d'occasion IAW59M alors que j'ai l'impression que les ECU ducati performance sont des IAW5A ?
- J'ai acheté aussi les cables, mais l'adaptateur OBD est avec une communication bluetooth
- Je ne suis pas sur un PC window, mais sur Mac, mais j'ai Window via VirtualBox, ce qui me permet d'émuler le port série COM1 de Window vers le port bluetooth du Mac.


Dans ce contexte, j'essaye de dialoguer avec l'ECU d'occasion,  non monté sur la moto, mais avec un branchement direct (les pins 12V, masse et K-line) et une alimentation externe.


J'ai donc lancer JPDIAG dans ce "contexte", mais ça ne marche pas (et donc je n'ai pas le CODE licence, car je n'ai pas les informations de l'ECU pour le demander)  et je n'arrive pas à identifier le problème :


J'arrive bien à ouvrir le port à 38440 baud.


J'ai bien une communication avec l'interface ELM , en hyper terminal, que ce soit sur Mac ou Window émulé.


Par contre l'ECU "refuse" de répondre à la première commande directe qui n'est pas une commande ELM : 


>AT Z
ELM327 v2.1
>AT I
TDA81 V0.13.0304
>AT RV
12.3V  (Je peut réguler le voltage et j'ai mis légèrement plus que 12V volontairement)
>AT SP 0 (recherche automatique du protocole qui trouve le ISO 14230-4 (KWP FAST) 
ok
>AT SP 5 (pour être directement dans le protocole KWP Fast)
ok
>01 00  (demande à l'ECU des IDs supportés)
BUS INIT: OK
7F 01 11


et la, c'est la m...
car cette réponse correspond à 7F : General Fails, 01: mon type de commande, 11 : Non supporté.


Et je ne sait pas si JPDiag et le dialogue en hyper terminal ne marche pas parce que : 


1/L'ECU est bloqué parce qu'il est d'occasion et qu'il y a le système anti-démmarage et que je n'ai pas la clef correspondante (de toute façon, l'ECU n'est pas monté sur la moto)


2/Mon environnement (Emulation windows, emulation port série COM1 sur bluetooth) est incompatible avec JPDiag (mais j'ai un minimum de dialogue en hyper terminal)


3/ Le protocole entre l'ELM et l'ECU n'est pas standard, et c'est normal que la commande 01 00 ne marche pas (mais ça n'explique pas pourquoi JPDiag ne marche pas.


4/ Il me faut un ECU IAW5A et pas un IAW59 ...


5/ Je suis largué (probablement la meilleure explication  Embarassed  )




Je vais commander un cable ELM USB, mais pas sur que ce soit le problème.
Je ne sais pas comment "effacer" l'anti-démmarage. J'ai trouvé sur internet un topic qui montre qu'il faut faire un petit trou pour pouvoir mettre à la masse, la ligne "boot" de l'ECU, mais je le ferrais en dernier recourt, car pour l'instant, je ne sait pas si c'est le problème et je découvre le monde de la déprogrammation des ECUs (je voulais juste viré la prise en compte de la sonde Lambda ...  Rolling Eyes )


Je suis évidement preneur de conseils ....


Merci

























Back to top
Publicité






PostPosted: Fri 2 Nov - 11:28 (2018)    Post subject: Publicité

PublicitéSupprimer les publicités ?
Back to top
jpl250rs
Administrateur

Offline

Joined: 05 Jun 2010
Posts: 10,348
Masculin
Bike / Moto: 899

PostPosted: Fri 2 Nov - 11:55 (2018)    Post subject: Presentation Reply with quote

bienvenu Wink
beaucoup de questions
1 - tu as choisi le mode elm pour faire fonctionner jpdiag ?
2 - tout le protocole n'est pas intégré , ca serait trop facile et universel avec n'importe quel soft de diag
3 - le cable elm ne te permettra pas d'aller plus loin pour atteindre ton but final ,il te faudra un cable kkl
4 - j'ai un outil qui peut faire ce que tu désire


Back to top
MSN
briseis
Map

Offline

Joined: 02 Nov 2018
Posts: 2
Localisation: Lyon
Masculin

PostPosted: Fri 2 Nov - 13:03 (2018)    Post subject: Presentation Reply with quote

Merci pour ces réponses.


1/ Oui, j'ai bien le mode  "cable ELM" pour faire fonctionner JPDiag, et pas les cables kkl. Je suis sous window 2000 (...)
JPDiag arrive bien à se connecter à l'ELM à 38000 baud, en fast init( il affiche la réponse de l'ELM : ELM327 v2.1 et est "vert" mais ensuite il semble être bloqué (pas d'affichage de la référence ECU, Hardware, etc ...). Il répond aux menus, mais n'arrive pas a acquérir les références ECU.


2/ Je suis naif ... Shocked


3/ Je commande un cable kkl usb.


4/ Super, ça m'intéresse. Mais plus précisement pour faire quoi ? : Débloquer le mode anti-démmarage de l'ECU ? désactiver la sonde Lambda pour le calcul de l'injection (qui est mon objectif principal), les deux ... En tout les cas, merci . Je reviens vers toi quand j'ai le cable kkl.


A bientôt


Back to top
jpl250rs
Administrateur

Offline

Joined: 05 Jun 2010
Posts: 10,348
Masculin
Bike / Moto: 899

PostPosted: Fri 2 Nov - 15:58 (2018)    Post subject: Presentation Reply with quote

les 2 mon capitaine

Back to top
MSN
Contenu Sponsorisé






PostPosted: Today at 23:40 (2018)    Post subject: Presentation

Back to top
Display posts from previous:   
Post new topic   Reply to topic    JPDiag Forum Index -> JPDiag -> Présentation All times are GMT + 1 Hour
Page 1 of 1

 
Jump to:  

Index | Administration Panel | Create a free forum | Free support forum | Free forums directory | Report a violation | Conditions générales d'utilisation
Powered by phpBB © 2001, 2005 phpBB Group